Subject: Re: Is Raknet still free software ?

From: "Ganael LAPLANCHE" <[email-masked]>

YzdTU7=EB=[email-masked]> <[email-masked]> <[email-masked]> <[email-masked]> <CAHcnhTNqNSyFE6m6z
qM_3=[email-masked]>
X-Mailer: Open WebMail 2.01 20030425
X-OriginatingIP: 157.99.64.43 ([email-masked])
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-15
Status: RO
Content-Length: 507
Lines: 16

On Tue, 20 Mar 2012 09:54:10 -0700, Kevin Jenkins wrote

> You might want to just delete the copyright header then or
> else it will be confusing to users. They are all the same I
> believe so a copy/paste in /Source/*.h;*.cpp and the same for
> DependentExtensions should do it

OK, thanks. I'll do that. Thanks !

Best regards,

--
Ganael LAPLANCHE <[email-masked]>
http://www.martymac.org | http://contribs.martymac.org
FreeBSD: martymac <[email-masked]>, http://www.FreeBSD.org

---

From: Kevin Jenkins <[email-masked]>
Date: Tue, 20 Mar 2012 09:54:10 -0700

You might want to just delete the copyright header then or else it will be
confusing to users. They are all the same I believe so a copy/paste in
/Source/*.h;*.cpp and the same for DependentExtensions should do it

On Wed, Dec 31, 1969 at 4:00 PM, Ganael LAPLANCHE <
[email-masked]> wrote:

> On Tue, 20 Mar 2012 08:36:57 -0700, Kevin Jenkins wrote
>
> > GPL3. After downloading you can change the comment at the top
> > of the headers to reflect this. RakNet 4 is under a different
> > license because it is used with game consoles that do not
> > allow GPL code.
>
> Thanks for this clarification. License file (GPLv3) will be bundled with
> packages, so I don't think modifying each single header is necessary.
> I'll also add a note into the FreeBSD port's Makefile about that.
>
> Thanks a lot !
> Best regards,
>
> --

---

From: "Ganael LAPLANCHE" <[email-masked]>

YzdTU7=EB=[email-masked]> <[email-masked]> <[email-masked]>
X-Mailer: Open WebMail 2.01 20030425
X-OriginatingIP: 157.99.64.43 ([email-masked])
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-15
Status: RO
Content-Length: 680
Lines: 19

Thanks a lot !
Best regards,

---

From: Kevin Jenkins <[email-masked]>
Date: Tue, 20 Mar 2012 08:36:57 -0700

GPL3. After downloading you can change the comment at the top of the
headers to reflect this. RakNet 4 is under a different license because it
is used with game consoles that do not allow GPL code.
On Mar 20, 2012 2:25 AM, "Ganael LAPLANCHE" <[email-masked]>
wrote:

> On Tue, 20 Mar 2012 01:06:32 -0700, Kevin Jenkins wrote
>
> > http://www.raknet.com/raknet/downloads/RakNet-3.902.zip
>
> Thanks ! Regarding the use of RakNet under GPL, is it GPL v2 or v3 ?
>
> Is RakNet 4.0x branch also published under GPL ?
>
> Thanks,
> Best regards,
>
> --

---

From: "Ganael LAPLANCHE" <[email-masked]>

YzdTU7=EB=[email-masked]>
X-Mailer: Open WebMail 2.01 20030425
X-OriginatingIP: 157.99.64.43 ([email-masked])
MIME-Version: 1.0
Content-Type: text/plain; charset=iso-8859-15
Status: RO
Content-Length: 432
Lines: 16

Thanks,
Best regards,

---

From: Kevin Jenkins <[email-masked]>
Date: Tue, 20 Mar 2012 01:06:32 -0700

On Wed, Dec 31, 1969 at 4:00 PM, Ganael LAPLANCHE <[email-masked]>wrote:

> On Mon, 19 Mar 2012 14:37:40 -0700, Kevin Jenkins wrote
>
> > What license is the version you have under? I am ok with
> > RakNet being used under the GPL
>
> We have 3.5.2 in ports, but license is not yet specified. I will
> indicate with the update that it is released under the GPL.
>
> Are sources for the lastest GPL'ed version available somewhere ?
>
> Thank you very much,
> Best regards,
>
> --

---

From: "Ganael LAPLANCHE" <[email-masked]>

Thank you very much,
Best regards,

---

From: Kevin Jenkins <[email-masked]>
Date: Mon, 19 Mar 2012 14:37:40 -0700

What license is the version you have under? I am ok with RakNet being used
under the GPL
On Mar 19, 2012 8:15 AM, "Ganael LAPLANCHE" <[email-masked]> wrote:

> Hello,
>
> I am the maintainer of the Raknet port on FreeBSD. Our version in the
> ports tree is 3.5.2. It is very old and I would like to update it.
>
> I would like to know if Raknet is still free software (it does not seem
> to be the case anymore) ? If yes, under which license is it available
> and where can I access the source code ?
>
> Best regards,
>
> --

---

From: "Ganael LAPLANCHE" <[email-masked]>

Hello,

Best regards,